Harness On-Prem Support Policy for Kubernetes

Updated 2 weeks ago by Michael Cretzman

This topic describes what Kubernetes versions Harness supports for its On-Prem editions.

What Kubernetes Versions Does Harness Support?

  • Harness supports Kubernetes Open Source versions 1.19, 1.18, 1.17.
  • Harness will officially support 3 previous versions from the last stable release. For example, the current most recent stable release is 1.19, and so Harness supports 1.18, 1.17, and 1.16.
  • Harness supports any other versions of Kubernetes you are using on a best effort basis.
  • Harness commits to support new minor versions within 3 months of the first stable release. For example, if the stable release of 1.19.0 occurs on August 15th, we will support it for compatibility by November 15th.

What Exactly Does it Mean to Support a Kubernetes Version?

Harness ensures that we do not introduce changes that will break compatibility with that version. For example, using a v1.18 feature that will not work in v1.16.

Installation or upgrade pre-flight checks will warn if the Kubernetes version is not currently supported.

If you are running an unsupported Kubernetes version and encounter a problem that is related to an incompatibility, you are required to upgrade your cluster. Harness will not issue a patch to support older, unsupported Kubernetes versions.


How did we do?